`

POJ1611解题报告

阅读更多
The Suspects
Time Limit: 1000MS  Memory Limit: 20000K
Total Submissions: 14274  Accepted: 6780

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
题意:有多个测试用例。第一行n表示学生数目,m表示组数。n=0且m=0时测试结束。每一行第一个值表示后面有多少个学生,后面就跟着学生的序号。默认第0个学生感染了SARS,每个与他同组的,或间接同组的都会感染。求最大感染人数。

分析:这是一道经典的并查集的题目,直接套用模板,几乎不用修改。只需将同一组的人union,最后求和0号同学同一组的有多少个人,那么就有多少人被感染。
#include<stdio.h>
#define NNUM 30000
int p[NNUM],rank[NNUM];
int suspect,n,m,u,x,y;
void makeSet()
{
   int i;
   for(i=0;i<NNUM;i++)
   {
       p[i]=i;
       rank[i]=0; 
   } 
}
int findSet(int i)
{
   if(i!=p[i])
   {
       p[i]=findSet(p[i]); 
   } 
   return p[i];
} 
void link(int i,int j)
{
   if(rank[i]>rank[j])
   {
       p[j]=p[i]; 
   } 
   else
   {
       p[i]=p[j];
       if(i==j)
       {
           rank[j]+=1; 
       } 
   }
}
void union1(int i,int j)
{
    link(findSet(i),findSet(j));
}
int main()
{
  while(scanf("%d%d",&n,&m)&&n+m)
  {
        int i,j;
        makeSet();
        for(i=0;i<m;i++)
        {
             scanf("%d",&u);
             scanf("%d",&x);
             
             for(j=1;j<u;j++)
             {
                 scanf("%d",&y);
                 union1(x,y); 
             }
        }
        
        int num=1;
        for(i=1;i<n;i++)
        {
            if(findSet(i)==findSet(0))
            {
                num++;
            } 
        }
        printf("%d\n",num);
  }
  
  system("pause");
  return 0; 
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics