`

Digital Roots

acm 
阅读更多
题目的链接为:http://acm.njupt.edu.cn/acmhome/problemdetail.do?&method=showdetail&id=1028
题目为:
Digital Roots
时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte
总提交:329            测试通过:112

描述


The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入


The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.


输出


For each integer in the input, output its digital root on a separate line of the output.


样例输入

24
39
0

样例输出

6
3

题意就不写了,是个人就看得明白。重点是,这本身一道极其水的题目,却在我没有考虑输入的数字可能无限大的情况下,硬是WA了N次。我都佩服我自己了....考虑问题居然这样不经过大脑。
#include<iostream>
using namespace std;
int main(){
    
    string str;
    while(cin>>str&&str!="0"){
            
        int num=0;                  
        for(int i=0;i<str.length();i++){
                   
                   num+=str[i]-'0';
                   if(num>9){
                      num=num/10+num%10;          
                   }
        }    
        cout<<num<<endl;                      
    }
    
    system("pause");    
    return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics